Audio/Video with SIPE on Ubuntu 12.04

I don’t know why, but Ubuntu packages for SIPE keep being defined without Audio/Video support…
Why ?

If you want to get things working, you need to compile it yourself.
I already did it for Ubuntu 10.04 in article Pidgin & SIPE latest versions on Ubuntu 10.04.
Things are even simpler on Ubuntu 12.04.

Remove existing sipe package

To avoid any conflict:

sudo apt-get remove pidgin-sipe

Install missing packages

In order to properly compile, you may need to install some packages:

sudo apt-get install libpurple-dev
sudo apt-get install libnss3-dev
sudo apt-get install libxml2-dev
sudo apt-get install libnice-dev
sudo apt-get install libgstreamer0.10-dev


Note: I already installed my environment for development with several packages, such as

sudo apt-get install build-essential

Compile sipe package

You should download it from SIPE web site repository

Then:

./configure --prefix=/usr


Check that Audio/Video has been automatically selected in the “make” command above, like here:
(...)
Build purple plugin
PURPLE_CFLAGS : -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include -I/usr/include/libpurple
PURPLE_LIBS : -lpurple -lglib-2.0
Voice and video: enabled
(...)

Otherwise check above why it has not been selected. Probably missing some *-dev package…

Next steps:

make
sudo make install

That should be all !
Just need to launch pidgin and start using it for Commnicator/Lync connections…

4 thoughts on “Audio/Video with SIPE on Ubuntu 12.04

  1. Hi Raistlin, firstly thanks for the nice precise blog as this is a nice and simple to follow. Don’t know if you can shed any light on this, but I can connect to Office 365 Lync and have chat’s no problems. I’ve managed to get an audio call working twice and a video working once. It seems as though 1 in every 10 or 20 attempts may work. I’m on 12.04LTS 64 bit with 1.15.1 of pidgin-sipe compiles as per your instructions. Obviously can work as has done, just so hit and miss – actually more miss. I’m usually a Windows user and loving working with Linux, but must confess pulling my hair out on this one. Feel like it should either work or not….. Anyhow if you have any thoughts, would appreciate it.

    Thanks,

    Scott

    • Hi Scott,

      Sorry, I never tried with Office 365 Lync (only the “standard” Lync software that you install on your laptop).
      May be someone else walking around has some feedback to provide ?

    • Hi Krihna,
      Thanks for your feedback.
      So far, I’m still running 12.04 on my laptop, but I plan to move to 16.04 soon… So, I will have to update this article :-) Stay tuned !

Leave a Reply to Thierry Cancel reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>


Warning: fsockopen() [function.fsockopen]: php_network_getaddresses: getaddrinfo failed: Name or service not known in /home/alphamat/www/blog/wp-content/plugins/sweetcaptcha-revolutionary-free-captcha-service/library/sweetcaptcha.php on line 81

Warning: fsockopen() [function.fsockopen]: unable to connect to www.sweetcaptcha.com:80 (php_network_getaddresses: getaddrinfo failed: Name or service not known) in /home/alphamat/www/blog/wp-content/plugins/sweetcaptcha-revolutionary-free-captcha-service/library/sweetcaptcha.php on line 81